"Contact your company's PitneyShip subscription holder to add postage" on the SendPro Mailstation
If you see the message "Contact your company's PitneyShip subscription holder to add postage" try adding postage directly on your device.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (2H00, 8H00, 9H00), SendPro® Mailstation, SendPro® Mailstation LITE (HZ0L)
Issue
The message "Contact your company's PitneyShip subscription holder to add postage" appears instead of a Refill button when you try to add postage to SendPro Mailstation at pitneybowes.com
Cause
Only the PitneyShip subscriber email can refill postage for SendPro Mailstation at pitneybowes.com.
Resolution
Contact your SendPro Online or PitneyShip subscription holder or refill postage on your device.
Related topicsUPDATED: July 17, 2024