"Internet not detected" when using PC Meter Connect on the mailstation series and DM100i-DM475

Check your settings, your network configurations, and your PC Meter Connect version to resolve the "Internet not detected" message on the mailstation, mailstation2, DM100i, DM125, DM200L, DM225, DM300C, DM400C and DM475.
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™, DM225™, DM300C™, DM400C™, DM475™, PC Meter Connect™

Issue

Alert: The USPS has discontinued all IBI meter technology, and many devices must be returned and withdrawn from service by the end of 2024. If your device is affected, new business rules will disrupt your mailing operation. Check Your Account to see if your device is affected and contact your Account Representative to migrate to a compliant solution.

PC Meter Connect displays the message Internet not detected.

Cause

PC Meter Connect cannot detect the internet and the Pitney Bowes Data Center. 

Resolution

Solution 1: Check to ensure that you have the latest version of PC Meter Connect

  1. The latest version of PC Meter Connect desktop application is 05.00.0081.
  2. Right-click on the PC Meter Connect system tray icon (small icons by the clock).
    PC Meter Connect icon in system tray
  3. Select About PC Meter Connect.
  4. If you do not have the latest version, uninstall and reinstall it:
    1. Right-click on the system tray icon and select Exit.
    2. Unplug your USB cable from your meter and your computer.
      pcmc-usb-meter-to-laptop
    3. Unplug your power cord from the back of your meter.
      pcmc-usb-laptop-and-power
    4. Select Windows Start > Control Panel > Programs and Features.
    5. Select PC Meter Connect and select Uninstall.
    6. Download and install the latest version of PC Meter Connect .
  5. If you reinstalled PC Meter Connect, restart your meter and your computer:
    1. Unplug your power cord.
    2. Wait one full minute.
    3. Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.
    4. Restart your computer by closing all open programs and selecting Shut down from the Windows Start menu.
    5. Once your computer has completely shut down, turn it back on.
    6. Attempt your connection again.

If your issue is not resolved, try Solution 2.

Solution 2: Make sure your network is configured properly

Make sure that your network is configured to allow the meter to communicate with the Pitney Bowes Data Center. Have your IT department review Networking and connectivity details for the mailstation series and DM125-DM475 to ensure compatibility.

If your issue is not resolved, try Solution 3.

Solution 3: Check your settings

Follow these steps on your computer:
  1. Open the Windows Control Panel.
  2. Select Network and Internet > Internet Options or just Internet Options (options vary depending on how your Control Panel is configured).
  3. Select the Connections tab.
  4. Select LAN Settings.
  5. Make sure that both boxes are checked:
    • Automatically detect settings.
    • Use automatic configuration script.
      Note: Contact your IT department for the address for the script or additional information about your network configuration.
  6. Select OK.

UPDATED: September 25, 2024