Error code 507 on the Connect+ Series and SendPro P-Series
Learn how to resolve error code 507 on the Connect+ Series and SendPro P-Series
Products affected: Connect+™ 500W, Connect+™ 1000, Connect+™ 2000, Connect+™ 3000, SendPro™; P1000, SendPro™; P1500, SendPro™; P2000, SendPro™ P3000
Issue
Error code 507 appears on the display.
Cause
Error code 507 appears on the display when you try to open Manage Accounts.
Resolution
Reboot the meter.
- Select the gear from the lower right corner of the Home screen.
- Select Shut Down from the menu.
- Select Shut Down from the pop-up.
- Wait for the display and blue light to go out. This may take a few minutes.
- Press the Power button.
UPDATED: June 04, 2021