Scale not weighing correctly on the DM100i, DM125

Zero the scale, make sure your scale is level and restart your meterif the scale is not weighing correctly.

Products affected: DM100®i and DM125™

Issue

Your mailpiece is not weighed correctly by your scale.

Cause

  • Your scale may not communicate with your meter.
  • Your scale may not be level.

Resolution

There are three ways to troubleshoot this issue; try them in this order:

  1. Zero your scale
  2. Make sure your scale is level
  3. Restart your meter

Solution 1: Zero your scale

  1. Remove any items from your scale.
  2. Select Scale from the Home screen.
  3. Select Zero the scale.
  4. Test your scale with an item of known weight.

If you still need help, try Solution 2.

Solution 2: Make sure your scale is level

It is possible that the top portion of the scale is not installed properly.

  1. Take the top cover off of your scale.
  2. Reseat the top portion of your scale, ensuring that it is level.
  3. Test your scale with an item of known weight. If the display shows 0 G with an item, please remove the top portion again and turn it 180 degrees and install it once again. Test the scale once again.

If you still need help, try Solution 3.

Solution 3: Restart your meter

  1. Remove your scale from the top of your meter.
  2. Unplug the power cord.
  3. Wait one to three minutes.
  4. While waiting, put your scale back on top of your meter.
  5. Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.
  6. Test your scale with an item of known weight.

UPDATED: 25 March 2025