"Please enter a valid serial or meter number" message appears when registering for Your Account
Learn how to resolve the message "Please enter a valid serial or meter number" when registering for Your Account.
Issue
The message "Please Enter a valid Serial Number" appears when registering for Your Account.
Cause
The serial number you are using to register is not recognised.
Resolution
- Confirm the country flag in the top right corner is the same location as the account address.
- Verify the serial number is correct.
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UPDATED: 30 October 2024