Frozen screen on the SendPro MailCenter 1000, 2000, and 3000
Return to the Hom screen, check the USB cable is connected or try another USB port to resolve a frozen screen.
Products affected: SendPro® MailCenter 1000, SendPro® MailCenter 2000, SendPro® MailCenter 3000
Issue
The touchscreen does not respond.
Cause
The touchscreen does not connect or malfunctions.
Resolution
Solution 1: Return to the Home screen
Press the Home button. The task you perform may not be responding, but the meter may still be working.
Solution 2: Check the USB cable
- Locate the USB cable coming from the base of the monitor stand.
- Make sure the USB cable is securely plugged into the USB port on the back of the meter.
If this does not work, go to Solution 3.
Solution 3: Try another USB port
- Plug the USB cable into another available port if one is available.
Related Topics
UPDATED: 15 April 2024