Wrong email address receives email notifications in PitneyShip Pro

If the wrong email address receives email notifications from the system, the sender address used for shipments contains that email address.
Products affected: PitneyShip® Pro

Issue

The wrong email address receives email notifications from PitneyShip Pro.

Cause

The sender address used for shipments contains that email address.

Resolution

Verify that the sender address being used contains the correct email address. If you have multiple users or locations, each one will need to verify their sender addresses.

  1. From the Shipping menu, select Create Shipping Label.
  2. In the Sender section, select the sender address and select Edit sender address.
  3. Update the email address in the Email field.
  4. Select Done.

If you have several sender addresses, you can view them under Settings > Address Book by changing the All Types menu to Sender. Select the edit icon next to each sender address to view and update.

UPDATED: 01 December 2023