"DeviceHub Registration failed" message when activating DeviceHub in PitneyShip Pro
If the message "DeviceHub Registration failed" appears, there may be an issue with your network blocking the activation, or DeviceHub may need to be uninstalled and reinstalled.
Products affected: PitneyShip™ Pro
Issue
When activating DeviceHub, The message "DeviceHub Registration failed" appears.
Cause
There may be an issue with your network blocking activation of DeviceHub, or DeviceHub may need to be uninstalled and reinstalled.
Resolution
- Solution 1: Uninstall and Reinstall DeviceHub
- Solution 2: Check the network specifications for DeviceHub
Solution 1: Uninstall and Reinstall DeviceHub
To uninstall DeviceHub, see:
To install DeviceHub, see:
Solution 2: Check the network specifications for DeviceHub
Review the DeviceHub Networking Requirements to ensure that your network allows for DeviceHub activation and communication. Contact your IT department if needed.
UPDATED: 24 January 2024