Resolving the steady red power light on the SendPro Mailstation
If the power light on your SendPro Mailstation is steady red, follow these steps to restart the device.
Products affected: SendPro® Mailstation
Issue
Steady red power light
Cause
An internal error has occurred.
A steady red light may be an indicator there is no ink cartridge installed.
Resolution
If you see a steady red power light during installation and before you have installed the ink cartridge, this is as expected, follow the on-screen prompts. The power button will turn steady white after you install the ink.
If you see a steady red power light when you are using the machine, try these solutions in order:
- Solution 1: Check Ink
- Solution 2: Restart the device
- Solution 3: Physically disconnect and reconnect the device
Solution 1: Check Ink
Check to see if ink is installed.
Solution 2: Restart the device
- Disconnect the USB scale.
- Hold the power button until the screen displays Shutting Down.
- Once the device is off, wait 5 seconds.
- Tap the power button.
Solution 3: Physically disconnect and reconnect the device
If the device does not shut down with the power button
- Disconnect the power cord from the back of the machine.
- Wait ten seconds.
- Plug the cord back in firmly.
- Tap the power button.
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UPDATED: 20 June 2023