Resolving the flashing red power light on the SendPro Mailstation
If the power light on your SendPro Mailstation is flashing red, follow these steps to restart the device.
Products affected: SendPro® Mailstation
Issue
The device has a flashing red power light and you can not process mail.
Cause
An internal error has occurred.
Resolution
To resolve the flashing red power light follow the steps in Solution 1. If Solution 1 does not resolve the issue try Solution 2.
- Solution 1: Check range locking device
- Solution 2: Restart the device
- Solution 3: Physically disconnect and reconnect the device.
Solution 1: Check orange locking device
Ensure you have removed the orange locking device from the printer carriage found inside the ink door.
Solution 2: Restart the device
- Disconnect the USB scale.
- Hold the power button until the screen displays Shutting Down.
- Once the device is off, wait 5 seconds.
- Tap the power button.
Solution 3: Physically disconnect and reconnect the device
If the device does not shut down with the power button.
- Disconnect the power cord from the back of the machine.
- Wait ten seconds.
- Plug the cord back in firmly.
- Tap the power button.
UPDATED: 20 June 2023