"Connection failed" or "Connection Error" message on DH (DeviceHub) system tray icon in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
If the DH (DeviceHub) system tray icon shows a red exclamation point icon with the message "Connection failed", and when you click on the icon, it says "Connection Error: Click Reconnect from menu below", your network settings may need to be adjusted.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
The DeviceHub "DH" system tray icon shows a red exclamation point icon with the message "Connection failed", and when you click on the icon, it says "Connection Error: Click Reconnect from menu below".
Cause
MQTT connections on port 443/8883 to devicehub.pitneybowes.com are not allowed.
Resolution
Solution 1: Check the DeviceHub Networking Requirements
Make sure that all of the DeviceHub Networking Requirements are met. Contact your IT department for assistance if needed.
Solution 2: Manually activate DeviceHub
Try manually activating DeviceHub:
- Select Settings > My Devices..
- Select Activate DeviceHub.
UPDATED: February 20, 2025