"Invalid or missing payment Carrier Account. [120412] UPS account number..." message in ShipAccel

The message "Invalid or missing payment Carrier Account. [120412] UPS account number that was provided as Freight Collect billing method cannot be the same as Shipper Number" appears when using Third Party or Recipient billing if the Bill To account number you entered is already one of your carrier accounts.

Products affected: ShipAccel

Issue

The message "Invalid or missing payment Carrier Account. [120412] UPS account number that was provided as Freight Collect billing method cannot be the same as Shipper Number" appears when using Third Party or Recipient billing.

Cause

The Bill To account number you entered is already one of your carrier accounts.

Resolution

When selecting Bill To > Third Party or Bill To > Recipient, you cannot use a UPS account that is already one of your subscription's carrier accounts. Enter a different UPS account number.

If you are trying to bill your own UPS account for a return label, it is not necessary to enter your UPS account number in the Bill To section. The Return Label will bill to the UPS account selected under the Packaging options.

UPDATED: December 12, 2024