"Seagull Driver Failed to Install" message when installing a PitneyShip Cube via Wi-Fi on a Windows PC
Learn how to reslove the "Seagull Driver Failed to Install" message when installing a PitneyShip Cube via Wi-Fi on a Windows PC.
Products affected: PitneyShip Cube™
Issue
The PitneyShip Cube Wi-Fi driver fails to install.
Cause
A forced reboot causes the failure.
Resolution
- Click Close on the error message.
- On your computer, go to Start > Settings > Printers and Scanners.
- Click Add a printer or scanner.
- Click The printer that I want isn't listed or Add Manually.
- Click Add a local printer or network printer with manual settings, and click Next.
- Under Choose a printer port, select Use an existing port.
- Select the Standard TCP/IP Port, and click Next.
Note: The IP address displayed with that port should match the IP address on the PitneyShip Cube configuration report. To print out a configuration report, short press the Wi-Fi button located on the back of the PitneyShip Cube. This will print out the PitneyShip Cube configuration report. - On the Install Printer Driver window, select Pitney Bowes > Pitney Bowes Printer and Scale > Next. If multiple versions of the Pitney Bowes Printer and Scale driver are displayed, select version 2023.4.1.0.
- If asked "Which version of the driver do you want to use?," select Use the driver that is currently installed and click Next.
- Click Next.
- Select Do not share this printer and click Next.
- Select Finish.
- On your computer, go to Start > Settings > Printers and Scanners. Confirm that the installation was successful. Your PitneyShip Cube will be on your printer list as Pitney Bowes Printer and Scale.
- Return to PitneyShip and go to Settings > My Devices. Refresh the page if the Pitney Bowes Printer and Scale is not listed. DeviceHub should activate and the printer should be listed.
If you need further assistance, please chat with us.
UPDATED: November 08, 2024