Multi Factor Authentication (MFA) email not received when adding postage in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

If the authentication email is not received when adding postage, the email may be in your Spam or Junk folder, or your network may be blocking these email communications.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When adding funds, the authentication email is not received.

Cause

The email may be in your Spam or Junk folder, or your network may be blocking these email communications.

Resolution

  1. Check your email Junk or Spam folder for the authentication email.
  2. Verify with your IT department that emails from no-reply@ccbs.saase2e.pitneybowes.com are allowed on your network.
  3. Try adding no-reply@ccbs.saase2e.pitneybowes.com as a contact in your email address book.

UPDATED: July 12, 2024