"Looks like your DeviceHub couldn’t be activated. Please try again later." message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
The message "Looks like your DeviceHub couldn’t be activated. Please try again later." means that your DeviceHub version is out of date.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
When activating DeviceHub, the message "Looks like your DeviceHub couldn’t be activated. Please try again later." appears.
Cause
Your DeviceHub version is out of date.
Resolution
Solution 1: Update DeviceHub
Update DeviceHub to the latest version and activate it. See:
If the issue is not resolved, try solution 2.
Solution 2: Uninstall and Reinstall DeviceHub
To uninstall DeviceHub, see:
To install DeviceHub, see:
UPDATED: July 12, 2024