A rate of 0.00 is provided after the UPS OAuth migration in SendPro Enterprise

Learn how to resolve the issue when the UPS rate appears at 0.00 in SendPro Enterprise after the UPS OAuth migration.
Products affected: SendPro® Enterprise

Issue

The UPS shipment rate is 0.00 after the OAuth migration in SendPro Enterprise.

Cause

The software is attempting to acquire a discounted rate for an account that is not linked or for an account which SendPro Enterprise does not have full access to. This can occur due to a variation in the order of operations during OAuth onboarding or configuration. Usually, the token must be created after the account is associated with the UPS.com profile when a Payment Method is added.

Resolution

Verify the account is configured correctly on the carrier side:

  1. Go to UPS.com.
  2. Cick Log In in the upper right corner.
  3. If you have a login, enter it now, otherwise, select Sign Up and create your account.
  4. After Logging in, in the upper right corner select the circle icon with a letter in the middle (or the three parallel lines next to it) and then click Accounts and Payment.
    • Confirm if a Payment Method is configured. If so, skip to steps 6-8.
    • Click Add a Payment Method and select Add Existing Account, it will request that you add your UPS Account Number, nickname, and postal code.
  5. You will have two options to verify your UPS account:
    • PIN: Tied to the email that was used to create the account
    • Invoice Data: A recent invoice from UPS for billing
  6. After the account is verified and added to your payment methods on your UPS.com profile, repeat steps 5 and 6 for each additional account.

If a payment method is added try to rate again, otherwise, continue with the steps below:

  1. Access the UPS API OAuth Setup application within your SendPro Enterprise tenant.
  2. Select the Edit button next to the UPS Account Group associated with the UPS account in question.
  3. Select Get Token to link the selected accounts with your UPS.com account.
    • You are directed to the UPS.com log in page. After logging in, you will receive the confirmation message "Account Group has been successfully linked to your account".
    • Note: If you see a different message, contact support at 1-800-888-0286 > shipping > SendPro Enterprise.
  4. Close the Requesting OAuth Token From UPS API box.
  5. Select Save and Close.
  6. Verify the rate is displaying as expected.

If you need further assistance, please chat with us.

UPDATED: July 08, 2024