"Missing or invalid shipper number" error displays after UPS OAuth migration in SendPro Enterprise
Learn how to resolve the error message "Missing or invalid shipper number" when attempting to process a UPS shipment after the UPS OAuth migration in SendPro Enterprise.
Issue
The error message "Missing or invalid shipper number" displays when attempting to process a UPS shipment after the UPS OAuth migration in SendPro Enterprise.
Cause
This error is the result of a failure in the configuration of the UPS account on UPS.com
Resolution
Add a Payment Method to the associated UPS.com account/profile:
- Go to UPS.com.
- Click Log In in the upper right corner.
- If you have a login, enter it now, otherwise, select Sign Up and create your account.
- After Logging in, in the upper right corner select the circle icon with a letter in the middle (or the three parallel lines next to it) and then click Accounts and Payment.
- Click Add a Payment Method menu and select Add Existing Account, it will request that you add your UPS Account Number, nickname, and postal code.
- Verify your UPS account. The two options for this are:
- PIN: Tied to the email that was used to create the account
- Invoice Data: A recent invoice from UPS for billing
- After the account is verified and added to your Payment Methods on your UPS.com profile, repeat steps 5 and 6 for each additional account.
See Applying the UPS OAuth authentication method to your UPS carrier in SendPro Enterprise for full instructions.
UPDATED: July 03, 2024