There was a problem adding funds message on the SendPro Mailstation

If the SendPro® Mailstation postage balance is funded by a credit card, there may be an issue with the card. Try updating the card in PitneyShip.
Products affected: SendPro® Mailstation

Issue

"There was a problem adding funds. There's a good chance it's a problem on our end. Wait a moment and try again." message appears when refilling postage on the SendPro Mailstation.

Cause

There is a possible issue with the postage funding method for the SendPro Mailstation.

Resolution

If the SendPro Mailstation postage balance is funded by a credit card, there may be an issue with the card. Try updating the card in PitneyShip.

If this does not resolve the issue or you are using another funding method like Purchase Power or Reserve Account, please chat with us.

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UPDATED: January 13, 2025