"Failed to connect with PitneyShip Cube! Please restart your printer and try again" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
The message "Failed to connect with PitneyShip Cube! Please restart your printer and try again" means that PitneyShip Cube is either offline, or there is an issue with DeviceHub.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, PitneyShip™ Cube
Issue
The message "There was a problem with your shipping label. Failed to connect with PitneyShip Cube! Please restart your printer and try again" appears.
Cause
The PitneyShip Cube is either offline, or there is an issue with DeviceHub.
Resolution
- Solution 1: Make sure that your PitneyShip Cube is installed, connected, and online
- Solution 2: Make sure that DeviceHub is installed
- Solution 3: Verify that DeviceHub is running
- Solution 4: Reconnect DeviceHub
- Solution 5: Activate DeviceHub
Solution 1: Make sure that your PitneyShip Cube is installed, connected, and online
- In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, go to Settings > My Devices.
- Verify that your printer shows an Online or Idle status.
- If the printer is still not listed, or printer status is Offline or Other, check the following:
- Make sure that the printer is installed on the computer. If it is not, see Installing the PitneyShip Cube driver on an additional computer to download and install the latest print driver.
- In Windows, go to Settings > Devices > Printers and make sure that your printer is present and online.
- On Mac, go to Apple menu > System Settings > Printers & Scanners and make sure that your printer is present and online.
- Verify that the printer is turned on and awake.
- Verify that the printer is correctly connected to the computer.
- Once the printer is connected and online, try to print again.
Solution 2: Make sure that DeviceHub is installed
To install DeviceHub, see:
Solution 3: Verify that DeviceHub is running
There should be a DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar to show that it is running.
If this icon is missing, find DeviceHub in your programs list and restart it.
Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 4: Reconnect DeviceHub
- Find the DeviceHub icon in Windows system tray (small icons near the clock) or Mac OS menu bar.
- Right-click on the DeviceHub icon and choose Reconnect.
- Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 5: Activate DeviceHub
- Select Settings > My Devices.
- Select Activate DeviceHub.
- Click the Activate button again in the pop-up window.
- If successful, a new browser tab window will open with a "DeviceHub registered successfully!" message.
- Close the new browser tab and select Settings > My Devices again.
- If your printers are still not displayed, click the Refresh button on the My Devices page.
When the PitneyShip Cube appears, and shows online, try printing again.
UPDATED: December 21, 2023