"There is an error processing your request" message when printing shipping labels using the PitneyShip Cube

Learn how to resolve the error "There is an error processing your request" when printing shipping labels using the PitneyShip Cube.
Products Affected: PitneyShip™ Cube

Issue

"There is an error processing your request" message appears in PitneyShip or PitneyShip Pro when attempting to print shipping labels using the PitneyShip Cube.

Cause

Both the Wi-Fi and USB printer drivers for the PitneyShip Cube are installed on the same computer. The drivers need to be uninstalled, and only one instance of the PitneyShip Cube printer driver should be reinstalled.

Resolution

Windows

  1. For Windows 10, select Start > Settings > Devices > Printers & scanners. For Windows 11, select Start > Settings > Bluetooth & devices > Printers & scanners.
  2. Under the Printers & Scanners section, select the Pitney Bowes Printer and Scale to remove.
  3. Click the Remove device button.
  4. Click the Yes button.
  5. Repeat these steps for the second instance of the Pitney Bowes Printer and Scale in the list.

Once the drivers are removed, only one of the PitneyShip Cube drivers should be installed. See Installing the PitneyShip Cube driver on an additional computer for steps on downloading the PitneyShip Cube driver.

Mac Ventura

  1. On your Mac, select the Apple menu > System Settings.
  2. Click Printers & Scanners from the sidebar.
  3. Locate the Pitney Bowes Printer and Scale in the list.
  4. On the keyboard, select Control + click on the Pitney Bowes Printer and Scale at the same time.
  5. Select Remove Printer, then click Remove Printer.
  6. Repeat the steps above for the second instance of the Pitney Bowes Printer and Scale in the list.

Once the drivers are removed, only one of the PitneyShip Cube drivers should be installed. See Installing the PitneyShip Cube driver on an additional computer for steps on downloading the PitneyShip Cube driver.

Mac Monterey or Big Sur

  1. Select the Apple menu > System Preferences.
  2. Click Printers & Scanners.
  3. Select Pitney Bowes Printer and Scale from the list, then click the Remove button.
  4. Click Delete Printer.
  5. Repeat the steps above for the second instance of the Pitney Bowes Printer and Scale in the list.

Once the drivers are removed, only one of the PitneyShip Cube drivers should be installed. See Installing the PitneyShip Cube driver on an additional computer for steps on downloading the PitneyShip Cube driver.

 

UPDATED: July 07, 2023