"There was an error generating your label... [120121] The Shipper number cannot be used for this shipment" message when printing a UPS label in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

There was an error generating your label... [120121] The Shipper number cannot be used for this shipment" message when printing a UPS label means that there is an issue with the UPS account.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When printing a UPS label, the message "There was an error generating your label. Something went wrong. Please try again later.[120121] The Shipper's shipper number cannot be used for the shipment" appears.

Cause

There is an issue with UPS account being used.

Resolution

UPS Rate Account

If you are using a UPS account that was created in either SendPro Online or PitneyShip as a Pitney Bowes UPS Rate Account, contact UPS to find out if there is an issue with the status of the account you are using.

Important: For this kind of account, do not follow the steps below.

Non-UPS Rate Account

If you are using a UPS account that you established with UPS directly and is not a Pitney Bowes UPS Rate Account, follow these steps.

  1. Select Settings > Carriers.
  2. Select the delete icon next to the UPS carrier account.
  3. Select Delete.
  4. Select Add Carrier and enter the UPS account details to re-add it.

UPDATED: April 08, 2024