Resolve an ink leak on a Pitney Bowes postage meter

Learn how to resolve an ink leak on a Pitney Bowes postage meter.
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™ DM225™, DM300C™, DM400C™, DM450C™, DM475™, Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® 300

Issue

You have ink leaks, either inside or outside of the postage meter.

Cause

An internal component failed.

Resolution

Follow these steps to resolve your issue:

  1. Turn off the postage meter.
  2. Unplug the meter's power cord.

UPDATED: January 23, 2025