"The date format set by Windows (M/d/yy) is not accepted by Business Manager. See the LOG file for more information." message when opening Business Manager

Learn how to resolve the error "The date format set by Windows (M/d/yy) is not accepted by Business Manager. See the LOG file for more information." when trying to open Business Manager.
Products affected: Business Manager

Issue

When trying to open Business Manager, the error "The date format set by Windows (M/d/yy) is not accepted by Business Manager. See the LOG file for more information." displays.

Cause

Business Manager can only open with a Regional short date in the MM/dd/yyyy format.

Resolution

Change the date format setting in Windows:
  1. Select Start > Control Panel > Clock, Language, and Region > Region and Language.
  2. From the Short date menu, select MM/dd/yyyy.
  3. Select OK.
If you are running Business Manager with a different user that has administrator rights, you must select this date format for that user as well.

Use the Contact Us options below if you need further assistance.

UPDATED: November 14, 2022