Resolving the steady red power light on the SendPro Mailstation
If the power light on your SendPro Mailstation is steady red, follow these steps to restart the device.
Products affected: SendPro® Mailstation, SendPro® Mailstation LITE (HZ0L)
Issue
Steady red power light
Cause
An internal error has occurred.
A steady red light may be an indicator there is no ink cartridge installed.
A steady red light may be an indicator there is no ink cartridge installed.
Resolution
When you are installing the device
If you see this during installation, follow the on-screen prompts. The power button will turn steady white after you install the ink.
When you are using the device
Check to see if ink is installed.
Restart the device
- Hold the power button until the screen displays "Shutting Down."
- Once off wait 5 seconds.
- Tap the power button.
If the device does not shut down with the power button
- Disconnect the power cord from the back of the machine.
- Wait ten seconds.
- Plug the cord back in firmly.
- Tap the power button
If you need further assistance, please contact us.
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UPDATED: November 22, 2024