Resolving the flashing red power light on the SendPro Mailstation

If the power light on your SendPro Mailstation is flashing red, follow these steps to restart the device.
Products affected: SendPro® Mailstation, SendPro® Mailstation LITE (HZ0L)

Issue

The device has a flashing red power light and you can not process mail.

Cause

An internal error has occurred.

Resolution

To resolve the flashing red power light follow the steps in Solution 1. If Solution 1 does not resolve the issue try Solution 2.

Solution 1: Check orange locking device

Ensure you have removed the orange locking device from the printer carriage found inside the ink door.
img_ink_open_218x198

Solution 2: Restart the device

  1. Disconnect the USB scale.
  2. Hold the power button until the screen displays Shutting Down.
  3. Once the device is off, wait 5 seconds.
  4. Tap the power button.

If the device does not shut down with the power button, continue to the next solution.

Solution 3: Physically disconnect and reconnect the device

  1. Disconnect the power cord from the back of the machine.
  2. Wait ten seconds.
  3. Plug the cord back in firmly.
  4. Tap the power button.

If the red power light is still flashing and you heard the print carriage move when you restarted the device, continue to the next solution.

Solution 4: Reinstall the ink cartridge

  1. Tap Settings.
    settings
  2. Tap Ink Functions.
  3. Tap Replace Ink.
  4. Lift the ink door by pulling up on the tab.
    img_ink_open_218x198
  5. Remove the ink cartridge.
    Caution: Do not touch the metal parts; they may be hot. Do not shake the ink cartridge; this may cause ink to spill.
    1. Push the cartridge downward towards the table until you hear a click
    2. Pull the ink cartridge out from the device.
  6. Make sure the shipping tape has been removed from the ink cartridge.
  7. Insert the ink cartridge into the device with the red section of the label first.
    ink-cartridge-label
  8. Push the ink cartridge into the slot until it clicks.
    u6151
  9. Close the cover and follow the prompts on the screen.

If you need further assistance, please chat with us.

UPDATED: August 21, 2023