"Consignee Address is invalid - Postal Code is missing or invalid" message in SendPro Enterprise
Learn how to resolve the message "Consignee Address is invalid - Postal Code is missing or invalid" in SendPro Enterprise.
Products affected: SendPro® Enterprise
Issue
When shipping a USPS First class letter with Electronic Return Receipt (ERR) to one of the US Territories, the message "Consignee Address is invalid - Postal Code is missing or invalid" is displayed
Cause
USPS does not support ERR to US territories:
- American Samoa
- Guam
- Northern Mariana Islands
For Puerto Rico:
- SendPro Enterprise: When using the Certified Mail App to ship to Puerto Rico, the Ship To Address Country field needs to be populated with "Puerto Rico" and State field left blank.
For more information, see the USPS Electronic Return Receipt bulletin.
Resolution
Deselect the ERR option when shipping to US territories.
UPDATED: November 25, 2024