"Login Failed TrustFailure" message when opening ConnectRight Mailer
Learn how to resolve the message "Login Failed. TrustFailure: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel." when opening ConnectRight Mailer.
Products affected: ConnectRight™ Mailer
Issue
When opening ConnectRight Mailer, the following message appears:
"Login Failed
TrustFailure: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel."
TrustFailure: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel."
Cause
Your network's security certificate for https://ws.lortondata.com has expired.
Resolution
Notify your IT department that the security certificate for the website https://ws.lortondata.com needs to be renewed every 90 days.
Test Criteria
Permissions required
Admin, Client
Test Criteria
- Open web browser and go to https://ws.lortondata.com.
- In the browser's address bar next to the "https", make sure it shows that the connection to the site is secure.
- If you receive a message that there is a problem with this website's security certificate, as shown here, then the certificate is expired and your IT department needs to allow the website https://ws.lortondata.com to receive a new certificate every 90 days.
Permissions required
Admin, Client
UPDATED: August 14, 2021