Unable to print when using PitneyTrack Inbound with Google Chrome

Learn how to resolve printing failure when using PitneyTrack Inbound with Google Chrome.

Products affected: PitneyTrack® Inbound

Issue

  • Labels will not print.
  • A red triangle appears in the web browser's address field.
  • A red strike-through appears in the "https" portion of the PitneyTrack Inbound address in the web browser's address field.

Cause

Network security measures are preventing the components for web printing from loading.

Resolution

To enable printing, contact your IT department and have them either issue a certificate for https://sendsuitetracking.pitneybowes.com or add https://sendsuitetracking.pitneybowes.com to your computer's list of trusted sites.

UPDATED: November 21, 2024