"Please enter a valid Invoice Number" message appears when registering for Your Account
Learn how to resolve the message "Please enter a valid Invoice number" when registering for Your Account.
Issue
The message "Please Enter a valid Invoice Number" appears when registering for Your Account
Cause
The invoice number you are using to register is not recognised.
Resolution
- Confirm the country flag in the top right corner is the same location as the account address.
- Verify the invoice number is correct.
UPDATED: 19 December 2024