"Preparing Ink" message on the DM60

Restart your franking machine to resolve the message Preparing Ink.
Products affected: DM60™ (K722)

Issue

The Preparing Ink message shows continuously after installing a new ink cartridge or when installing your franking machine.

Cause

This message can indicate:

  • The franking machine is frozen.
  • There is an issue with the ink cartridge or the franking machine.

Resolution

Restart the franking machine. Follow these steps to restart safely:

  1. Unplug the power lead from the back of the franking machine.
  2. Wait one to three minutes.
  3. Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.

UPDATED: 15 June 2023