Troubleshooting connection issues with the Communication Device on the DM60

Try a different connection method, restart the franking machine and Communication Device, check the LEDs and reset the Communication device to resolve connection issues.
Products affected: DM60™ (K722)

Issue

The DM60 is unable to successfully connect via the Pitney Bowes Communication Device.
communication-device

Cause

Problems with the settings, a network point, or a firewall can cause network connection issues.

Resolution

Try the Communication Device troubleshooting solutions in this order:

  1. Try a different connection method
  2. Restart the franking machine and the Communication Device
  3. Diagnose the Communication Device using the LEDs
  4. Reset the Communication Device to factory default

Solution 1: Try a different connection method

We recommend that you switch to a faster, more reliable digital connection.

Order and install a SmartLink™ device

If trying a different connection method does not resolve your issue, try Solution 2.

Solution 2: Restart the franking machine and the Communication Device

  1. Unplug the power cord from the back of the franking machine.
  2. Unplug the USB cable from the back of the franking machine.
  3. Unplug the power cord from the Communication Device.
  4. If you have a wired connection, unplug the network cable from the Communication Device.
  5. Wait 30 seconds.
  6. Plug the network cable into the Communication Device. Make sure that the other end of the network cable is plugged into a working network router, switch, or wall jack.
  7. Plug the power cord into the Communication Device.
  8. Wait for an orange flashing LED (light) near the Communication Device's network jack.
    • If the LED does not turn on, make sure that the Communication Device is properly plugged in to a working power source.
    • If LED is red, either your network settings are blocking the connection, or the network cable is bad.
  9. Plug the USB cable into the franking machine.
  10. Plug the power cord into the franking machine.
  11. Check the network jack once the franking machine returns to the Home screen.
    • If the LED on the network jack flashes green, your connection should work.
    • If the LED does not flash green, go to the next solution.

If restarting the franking machine and the Communication Device does not resolve your issue, try Solution 3.

Solution 3: Diagnose the Communication Device using the LEDs

The LEDs near the network jack on the Communication Device have colours and blink patterns that indicate the status of the device.

If the LEDs do not blink green, see Troubleshooting blink codes and LED patterns.

If diagnosing the Communication Device using the LEDs does not resolve your issue, try Solution 4.

Solution 4: Reset the Communication Device to factory defaults

If your Communication Device does not work, you may need to restore your Communication Device to the factory settings. Read through the instructions before you begin. Select a method for restoring your factory settings:

Power Cycle method:

  1. Unplug the power cord from the Communication Device.
  2. Using a pen, press and hold in the small reset button on the Communication Device.
    comm device reset button
  3. While holding the reset button in, plug the power back into the Communication Device.
  4. Continue to hold the button in until the green LED lights up, then release. This takes about 10 seconds.
  5. After the green LED lights up, go back to the first solution and restart your franking machine and the Communication Device.

Button method:

  1. Turn on the Communication Device and make sure that the green and/or red LEDs are blinking.
  2. Use a pen to press and hold in the small reset button on the Communication Device until the LED turns green (about 2 seconds).
    comm device reset button
  3. After the green LED turns on, release the button.
    • If the green LED turns off and the red LED turns on, the process was successful. A few seconds later, the red LED turns off as the Communication Device resets itself.
    • If the LEDs start blinking again, the solution was not successful. Repeat steps 1-3.

If you are unable to connect to the internet, ask your IT department or internet provider to check the internet settings.

UPDATED: 14 July 2023