"Invalid Account Number" message on the DM60
Please chat with us to resolve the Invalid Account Number message.
Products affected: DM60™ (K722)
Issue
The "Invalid Account Number" message appears when installing or adding funds to your franking machine.
Cause
You may have an issue with your Pitney Bowes account.
Resolution
Please chat with us to resolve this error.
UPDATED: 14 July 2023