"Bug buddy" message on the Connect+ series and SendPro P

Learn how to resolve bug buddy errors on the Connect+ 500W, Connect+ 1000, Connect+ 2000, Connect+ 3000, SendPro P1000, SendPro P1500, SendPro P2000, and SendPro P3000.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000

Issue

Your franking machine displays the bug buddy screen and will not operate.

Cause

Bug buddy errors are errors reported by the operating system.

Resolution

  1. Press Cancel to clear the bug buddy screen.
Important: Saving the bug buddy log file is not necessary unless requested by Pitney Bowes technical support.
  1. Double-tap on the System Shutdown icon.
  2. Select Shutdown now.
  3. Once the screen has been dark for 10 seconds, press and hold the power button for 5 seconds.
  4. Wait one minute, then press the power button.
If the issue is unresolved, please use the Contact Us options below.

UPDATED: 14 August 2021