Resolve "System.ApplicationException: Your request failed because the carrier returned the following error: Unauthorized" when setting up Shipping API carrier in SendSuite Live
Learn how to resolve the error "System.ApplicationException: Your request failed because the carrier returned the following error: Unauthorized" when setting up a Shipping API carrier in SendSuite Live.
Products affected: SendSuite® Live
Issue
When attempting to set up Pitney Bowes Shipping API carrier, the following error message is displayed when requesting the account number:
Exception:
System.ApplicationException: Your request failed because the carrier returned the following error: Unauthorized
at Pierbridge.Carrier.Administration.GCS.GetNewToken(String baseUri, String KeyAndHeaderValue)
at Pierbridge.Carrier.Administration.GCS.Process
Exception:
System.ApplicationException: Your request failed because the carrier returned the following error: Unauthorized
at Pierbridge.Carrier.Administration.GCS.GetNewToken(String baseUri, String KeyAndHeaderValue)
at Pierbridge.Carrier.Administration.GCS.Process
Cause
This can be caused by either:
- A mismatch between the key and environment type, or
- An issue with the Pitney Bowes Shipping API account configuration
Resolution
To resolve this issue:
- Verify that you are using the correct key for your environment type:
- If SendSuite® Live is in Test mode, then you must use the provided Development keys.
- If SendSuite Live is in Live mode, then you must use the provided Production keys.
UPDATED: June 03, 2021