"Unable to Connect: Please check the Meter is connected. Failed to complete the OpenDevice sequence." in SendSuite Live
Learn how to resolve the error "Unable to Connect: Please check the Meter is connected. Failed to complete the OpenDevice sequence" in SendSuite Live.
Products affected: SendSuite® Live
Issue
When attempting to open a SendSuite® Live Mailroom project, it fails to connect to the meter and displays the following error message:
Unable to Connect: Please check the Meter is connected. Failed to complete the OpenDevice sequence.
Cause
A communication failure has occurred.
Resolution
If this error occurs after applying updates to the meter, reboot the meter by unplugging it, waiting one full minute, and plugging it back in.
- Other things to try: Run Internet Explorer with Administrator rights.
- Verify with your local IT department that the Connect+ meter has its own static IP address which is dedicated to this device only.
UPDATED: June 03, 2021