"Missing or invalid element: Contents Type" when shipping to APO or US Territory in SendSuite Live
Learn how to resolve the error "Missing or invalid element: Contents Type" when shipping to APO or US Territory in SendSuite Live.
Products affected: SendSuite® Live
Issue
When shipping to APO or US Territory, the error "Missing or invalid element: Contents Type" is displayed.
Cause
This is a configuration issue.
Resolution
For all APO/DPO/International shipments, a shipment content type must be provided in all ship requests. This element must be entered in PierbridgeShipRequest/ContentType. Valid values for this are:
- Gift
- Documents
- Sample
- Return
- Merchandise
- Other
- Open the Ship or Mailroom project for editing.
- Select the Ship or Mailroom project page.
- Drag a new list box control onto the project.
- Change the label to Content Type.
- Right-click the list box and select Data Properties.
- Change the control name to ContentType.
- Select the List Options tab and click New.
- Under Display Text, enter:
Gift
Sample
Documents
Merchandise
Return
Other
Sample
Documents
Merchandise
Return
Other
Important: Ensure that the content type is entered exactly as shown above – they are case-sensitive.
- Assign the Default check box to a blank option.
- Select the Use the same database value check box.
- Right-click on the Ship button and select Data Properties.
- Click Parameters. The XML Schema Request Parameters dialog box is displayed.
- Select the Content Type parameter check box.
- On the Value list, select Process.Control.ContentType.
Tip: If you have just added something to the project, it should be at the bottom of the available list.
- Click OK at each prompt, then click Save Changes. The transaction is now mapped and will be called when the button is clicked by the user.
UPDATED: August 14, 2021