"Please Enter a valid Account Number" message appears when registering for Your Account

Learn how to resolve the message "Please Enter a valid Account Number" when registering for Your Account.

Issue

The message "Please Enter a valid Account Number" appears when registering for Your Account.

Cause

The account number you are using to register is not recognised.

Resolution

  1. Confirm the country flag in the top right corner is the same location as the account address.
    Country location on the Pitney Bowes support site
  2. Verify the account number is correct.

If you need further assistance, please chat with us.

UPDATED: 19 December 2024