Unresponsive scale on the DM125, DM175 and DM195

Ensure that your scale is installed properly, zero your scale or reboot your meter to resolve your scale not weighing.
Products affected: DM125™, DM175™, DM195™

Issue

Your attached scale does not respond when you place an item on it.

Cause

  • Your meter does not communicate with your scale.
  • Your scale is defective.

Resolution

There are four ways to troubleshoot this issue; try them in this order:

  1. Watch the video
  2. Ensure that the scale is properly installed
  3. Zero your scale
  4. Reboot your meter

Solution 1: Watch the video

Solution 2: Ensure that the scale is properly installed

  1. Lift the scale off the top of the machine, then put it back on.
  2. Push down on the back of the scale to ensure the platform is positioned correctly.
  3. Wait 5 seconds, then press the Normal Presets button.

If this does not resolve your issue, try Solution 3.

Solution 3: Zero your scale

  1. Select SCALE.
  2. Select Zero the scale.
  3. Test your scale with an item of known weight.

If this does not resolve your issue, try Solution 4.

Solution 4: Reboot your meter

  1. Lift your scale off of your meter.
  2. Unplug your power cord.
  3. Wait three minutes. During this time:
    1. Turn your scale upside down.
    2. Verify that your scale pins are not bent.
  4. Plug your meter back in, and place your scale back on top of your meter.
  5. Test your scale with an item of known weight.

UPDATED: 06 May 2022

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