Unresponsive scale on the DM125, DM175 and DM195
Ensure that your scale is installed properly, zero your scale or reboot your meter to resolve your scale not weighing.
Products affected: DM125™, DM175™, DM195™
Issue
Your attached scale does not respond when you place an item on it.
Cause
- Your meter does not communicate with your scale.
- Your scale is defective.
Resolution
There are four ways to troubleshoot this issue; try them in this order:
Solution 1: Watch the video
Solution 2: Ensure that the scale is properly installed
- Lift the scale off the top of the machine, then put it back on.
- Push down on the back of the scale to ensure the platform is positioned correctly.
- Wait 5 seconds, then press the Normal Presets button.
If this does not resolve your issue, try Solution 3.
Solution 3: Zero your scale
- Select SCALE.
- Select Zero the scale.
- Test your scale with an item of known weight.
If this does not resolve your issue, try Solution 4.
Solution 4: Reboot your meter
- Lift your scale off of your meter.
- Unplug your power cord.
- Wait three minutes. During this time:
- Turn your scale upside down.
- Verify that your scale pins are not bent.
- Plug your meter back in, and place your scale back on top of your meter.
- Test your scale with an item of known weight.
UPDATED: 06 May 2022